[Solved!] Running TOR as Root on Backtrack 5

edited January 2013 in Tech & Games
I downloaded the TOR browser bundle from the TOR website and tried to use it exactly as I would do on my desktop running Ubuntu. However, TOR doesn't like you running as Root, causing the application to force close.

I managed to get it working without using Vidalia, but then I found that I couldn't set my own nodes and all sorts of other problems came up.

Basically, how do I run the TOR browser bundle as Root on Backtrack 5? I've looked all over the internet and can't find a thing :(


  • DfgDfg Admin
    edited May 2011
    Make a new user account. Make sure it's not root. Su to that accounts via CLI and then run TOR.
  • edited May 2011
    I want to keep as Root so that I can run all my backtrack tools properly without any problems. Also, once I get TOR running then I want to run things like Nmap through it with ProxyChains or whatever it's called.

    So yeah, I need to be root.
  • BaconPieBaconPie Regular
    edited May 2011
    In general, you shouldn't be running things as root. You should give your user access to the binary using groups.
  • edited May 2011

    Well, I eventually found out how to do it and it doesn't involve the TOR browser bundle or anything like that. If you're looking to run TOR on Backtrack 5 then have a look at this guide, for a start...


    Then once you've done that, you can follow the link at the end of the article. If you can't find that link, then click here...


    Once you've got TOR installed and up to date, you can then use it with ProxyChains to do all kinds of things like Nmap scans through TOR, etc. The Backtrack developers decided that they didn't want to include TOR with the distro as it's not necessary if you're doing a legitimate penetration test on a network/system/organization, which is totally fair. However, I believe that you should still have the opportunity to have a crack at using it, which is why I made this post :)

  • yokweyokwe Semo-Regulars
    edited January 2013
    I'm quite a bit late replying to this, obviously, but this post is to help out anyone Googling this and arriving here.

    If you have Tor Browser Bundle and you don't want to mess around with the instructions above, there's a much easier way to run the bundle as root.

    The advice above about avoiding running things as root is sound advice; however, some users are running BackTrack in a VM with snapshots taken and hence, are probably less concerned about that. Not to mention, many tools in BackTrack will not work unless you're actually logged in as root.

    1) Log in to BackTrack as root, per usual.
    2) Download the TBB, tar the archive, put the folder somewhere handy (I use Desktop).
    3) Open an editor (I use nano). Open the start-tor-browser script (e.g., if you unpacked to Desktop, read from /root/Desktop/[tor bundle folder]/start-tor-browser)
    4) Find the root check in the script:

    if [ "`id -u`" -eq 0 ]; then
    complain "The Tor Browser Bundle should not be run as root. Exiting."
    exit 1

    5) Simply comment out these four lines with #.
    6) Exit, save file, overwrite when prompted.

    That is all. The root restriction in TBB is just a quick UID check. There's no reason why it won't work as root; it's just a best-practice security measure that the developers enforced with that check.

    Once again, this advice is for those who aren't concerned with running things as root (e.g., running BackTrack on a VM with a healthy snapshot to revert to). If you don't have an absolute need to run something as root, then avoid it.
  • bornkillerbornkiller Administrator In your girlfriends snatch
    edited January 2013
    yokwe wrote: »
    I'm quite a bit late replying to this, obviously, but this post is to help out anyone Googling this and arriving here.
    Useful bump is a useful bump! Thanks for your input....;)
  • Darth BeaverDarth Beaver Meine Ehre heißt Treue
    edited January 2013
    Great bump and great first post. Welcome to our home.
Sign In or Register to comment.